CVE-2023-6852 kalcaddle KodExplorer app.php server-side request forgery

Medium 6.3 Published Updated

Remote attackers can exploit a server-side request forgery vulnerability in KodExplorer to access internal resources or bypass security controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-6852?

CVE-2023-6852 is a medium-severity server-side request forgery vulnerability in kalcaddle KodExplorer, published on 16 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability classified as critical has been found in kalcaddle KodExplorer up to 4.51.03. Affected is an unknown function of the file plugins/webodf/app.php. The manipulation leads to server-side request forgery. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.52.01 is able to address this issue. The name of the patch is 5cf233f7556b442100cf67b5e92d57ceabb126c6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-248220.

Weakness: CWE-918

Which versions are affected by CVE-2023-6852?

It affects 1 product.

Products include Kodcloud Kodexplorer.

How do I fix CVE-2023-6852?

No fix has been published for CVE-2023-6852 yet. Limit exposure of the affected software until one is available.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2023-6852 being exploited?

There is no known exploitation of CVE-2023-6852 in the wild and no public exploit code.

Sources

Also known as GHSA-v73r-f3cx-pm99.

Is CVE-2023-6852 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free