# CVE-2023-6909: Path Traversal: '\..\filename' in mlflow/mlflow

> Attackers can exploit path traversal in MLflow to read or modify arbitrary files on the server.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-mlflow-2023-6909, GHSA-5r3q-93q3-f978, PYSEC-2023-252

## What is CVE-2023-6909?

CVE-2023-6909 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 18 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Path Traversal: '\..\filename' in GitHub repository mlflow/mlflow prior to 2.9.2.

Weakness: CWE-29 (Path Traversal: '\..\filename')

## Which versions are affected by CVE-2023-6909?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 2.9.2 |
| `mlflow` | PyPI | All versions | 2.9.2 |
| `mlflow` | PyPI | All versions | 2.9.2 |
| `mlflow` | PyPI | All versions | 2.9.2 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2023-6909?

Upgrade mlflow to 2.9.2 or later.

## Is CVE-2023-6909 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6909 exists.

Public exploit code:

- Mlflow <2.9.2 - Path Traversal (nuclei): http/cves/2023/CVE-2023-6909.yaml

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6909 and fix it if it is affected.

What it is: CVE-2023-6909 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 18 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6909 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 2.9.2
- mlflow (PyPI): affected all versions; fixed in 2.9.2
- mlflow (PyPI): affected all versions; fixed in 2.9.2
- mlflow (PyPI): affected all versions; fixed in 2.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6909/ (Markdown: https://insights.sbomify.com/CVE-2023-6909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6909
- OSV: https://osv.dev/vulnerability/CVE-2023-6909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6909/
Summaries are generated and may contain mistakes; the official description above is the record.
