# CVE-2023-7028: GitLab Community and Enterprise Editions Improper Access Control

> Attackers can take over user accounts by receiving password reset emails sent to unverified addresses due to a flaw in the password recovery mechanism.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Yes, since 1 May 2024 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2024
- **Updated:** 15 Aug 2026
- **Also known as:** BIT-gitlab-2023-7028, GHSA-mgg5-84cv-fc3c, UBUNTU-CVE-2023-7028

## What is CVE-2023-7028?

CVE-2023-7028 is a critical authentication bypass vulnerability in Gitlab Gitlab, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.1 prior to 16.1.6, 16.2 prior to 16.2.9, 16.3 prior to 16.3.7, 16.4 prior to 16.4.5, 16.5 prior to 16.5.6, 16.6 prior to 16.6.4, and 16.7 prior to 16.7.2 in which user account password reset emails could be delivered to an unverified email address.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2023-7028?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.1.0 | 16.1.6, 16.2.9, 16.3.7, 16.4.5, 16.5.6, 16.6.4, 16.7.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2023-7028?

Upgrade gitlab to a fixed version for your release line: 16.1.6, 16.2.9, 16.3.7 or 16.4.5. US federal agencies must fix it by 22 May 2024.

## Is CVE-2023-7028 being exploited?

Yes. Attackers have exploited CVE-2023-7028 in the wild since at least 1 May 2024.

Public exploit code:

- This repository presents a proof-of-concept of CVE-2023-7028 (github_poc): https://github.com/Vozec/CVE-2023-7028
- CVE-2023-7028 (github_poc): https://github.com/RandomRobbieBF/CVE-2023-7028
- CVE-2023-7028 killer (github_poc): https://github.com/Esonhugh/gitlab_honeypot
- An issue has been discovered in GitLab CE/EE affecting all versions from 16.1 prior to 16.1.6, 16.2 prior to 16.2.9, 16.3 prior to 16.3.7, 16.4 prior to 16.4.5, 16.5 prior to 16.5.6, 16.6 prior to 16.6.4, and 16.7 prior to 16.7.2 in which user account password reset emails could be delivered to an unverified email address. (github_poc): https://github.com/duy-31/CVE-2023-7028
- Repository to install CVE-2023-7028 vulnerable Gitlab instance (github_poc): https://github.com/Trackflaw/CVE-2023-7028-Docker
- https://github.com/sariamubeen/CVE-2023-7028 (github_poc): https://github.com/sariamubeen/CVE-2023-7028

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)
- [CVE-2021-22175](https://insights.sbomify.com/CVE-2021-22175/): GitLab Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7028 and fix it if it is affected.

What it is: CVE-2023-7028 is a critical authentication bypass vulnerability in Gitlab Gitlab, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2023-7028 in the wild since at least 1 May 2024.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.1.0; fixed in 16.1.6, 16.2.9, 16.3.7, 16.4.5, 16.5.6, 16.6.4, 16.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7028/ (Markdown: https://insights.sbomify.com/CVE-2023-7028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7028
- OSV: https://osv.dev/vulnerability/CVE-2023-7028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7028/
Summaries are generated and may contain mistakes; the official description above is the record.
