{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-7029 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-7029 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-7029 is a medium-severity cross-site scripting vulnerability in maxfoundry MaxButtons – Create buttons, published on 5 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-7029 and fix it if it is affected.\n\nWhat it is: CVE-2023-7029 is a medium-severity cross-site scripting vulnerability in maxfoundry MaxButtons – Create buttons, published on 5 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-7029 in the wild and no public exploit code.\n\nAffected product: maxfoundry MaxButtons – Create buttons. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-7029/ (Markdown: https://insights.sbomify.com/CVE-2023-7029/index.md)","id":"CVE-2023-7029","markdown":"https://insights.sbomify.com/CVE-2023-7029/index.md","name":"CVE-2023-7029","record":{"aliases":["GHSA-cm2j-xhch-gm5q"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated attackers with contributor access can inject arbitrary scripts via shortcodes, leading to stored XSS execution on victim pages.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"maxbuttons","vendor":"maxfoundry"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The WordPress Button Plugin MaxButtons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including 9.7.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in version 9.7.6.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WordPress Button Plugin MaxButtons \u003c= 9.7.6 - Authenticated(Contributor+) Stored Cross-Site Scripting via shortcode","id":"CVE-2023-7029","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"Collapse-O-Matic \u003c= 1.8.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","id":"CVE-2023-7030"},"packages":[],"prev":{"headline":"GitLab Community and Enterprise Editions Improper Access Control","id":"CVE-2023-7028"},"products":["MaxButtons – Create buttons"],"published":"2024-02-05","related":[{"cvss_score":6.5,"headline":"WordPress MaxButtons Plugin \u003c= 9.5.3 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-36503","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":5.4,"headline":"WordPress Button Plugin MaxButtons \u003c 9.7.8 - Editor+ Stored XSS","id":"CVE-2024-3026","kev_date_added":null,"published":"2024-07-13"},{"cvss_score":5.3,"headline":"WordPress Button Plugin MaxButtons \u003c= 9.7.8 - Full Path Disclosure","id":"CVE-2024-6499","kev_date_added":null,"published":"2024-08-24"},{"cvss_score":4.8,"headline":"MaxButtons \u003c 9.8.1 - Admin+ Stored XSS via Button Width","id":"CVE-2024-10555","kev_date_added":null,"published":"2024-12-20"},{"cvss_score":4.7,"headline":"MaxButtons \u003c 9.8.1 - Admin+ Stored XSS via Text Color","id":"CVE-2024-8968","kev_date_added":null,"published":"2024-12-20"},{"cvss_score":4.4,"headline":"WordPress Button Plugin MaxButtons \u003c= 9.7.4 - Authenticated (Administrator+) Stored Cross-Site Scripting","id":"CVE-2023-6594","kev_date_added":null,"published":"2024-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["maxfoundry"]},"summary":"Authenticated attackers with contributor access can inject arbitrary scripts via shortcodes, leading to stored XSS execution on victim pages.","url":"https://insights.sbomify.com/CVE-2023-7029/"}