# CVE-2023-7029: WordPress Button Plugin MaxButtons <= 9.7.6 - Authenticated(Contributor+) Stored Cross-Site Scripting via shortcode

> Authenticated attackers with contributor access can inject arbitrary scripts via shortcodes, leading to stored XSS execution on victim pages.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Feb 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-cm2j-xhch-gm5q

## What is CVE-2023-7029?

CVE-2023-7029 is a medium-severity cross-site scripting vulnerability in maxfoundry MaxButtons – Create buttons, published on 5 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The WordPress Button Plugin MaxButtons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including 9.7.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in version 9.7.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-7029?

It affects 1 product.


Products: Maxfoundry Maxbuttons.

## How do I fix CVE-2023-7029?

No fix has been published for CVE-2023-7029 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-7029 being exploited?

There is no known exploitation of CVE-2023-7029 in the wild and no public exploit code.

## Other vulnerabilities in maxfoundry MaxButtons – Create buttons

- [CVE-2023-36503](https://insights.sbomify.com/CVE-2023-36503/): WordPress MaxButtons Plugin <= 9.5.3 is vulnerable to Cross Site Scripting (XSS) (medium 6.5)
- [CVE-2024-3026](https://insights.sbomify.com/CVE-2024-3026/): WordPress Button Plugin MaxButtons < 9.7.8 - Editor+ Stored XSS (medium 5.4)
- [CVE-2024-6499](https://insights.sbomify.com/CVE-2024-6499/): WordPress Button Plugin MaxButtons <= 9.7.8 - Full Path Disclosure (medium 5.3)
- [CVE-2024-10555](https://insights.sbomify.com/CVE-2024-10555/): MaxButtons < 9.8.1 - Admin+ Stored XSS via Button Width (medium 4.8)
- [CVE-2024-8968](https://insights.sbomify.com/CVE-2024-8968/): MaxButtons < 9.8.1 - Admin+ Stored XSS via Text Color (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7029 and fix it if it is affected.

What it is: CVE-2023-7029 is a medium-severity cross-site scripting vulnerability in maxfoundry MaxButtons – Create buttons, published on 5 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-7029 in the wild and no public exploit code.

Affected product: maxfoundry MaxButtons – Create buttons. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7029/ (Markdown: https://insights.sbomify.com/CVE-2023-7029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7029
- OSV: https://osv.dev/vulnerability/CVE-2023-7029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7029/
Summaries are generated and may contain mistakes; the official description above is the record.
