CVE-2023-7038 automad User Creation cross-site request forgery

Medium 4.3 Published Updated

Attackers can force authenticated users to create new accounts via cross-site request forgery in automad.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-7038?

CVE-2023-7038 is a medium-severity vulnerability in automad, published on 21 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in automad up to 1.10.9. It has been rated as problematic. This issue affects some unknown processing of the file /dashboard?controller=UserCollection::createUser of the component User Creation Handler. The manipulation leads to cross-site request forgery. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-248687. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-352

Which versions are affected by CVE-2023-7038?

2 open source packages ship an affected version, including automad/automad. It affects 1 product.

PackageAffectedFixed in
automad/automad PackagistAll versions2.0.0-alpha.1
automad/automad PackagistAll versions2.0.0-alpha.1

Products include Automad Automad.

How do I fix CVE-2023-7038?

Upgrade automad/automad to 2.0.0-alpha.1 or later.

Is CVE-2023-7038 being exploited?

There is no known exploitation of CVE-2023-7038 in the wild and no public exploit code.

Sources

Also known as GHSA-4j8w-p6hv-3qxc.

Is CVE-2023-7038 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free