{"answers":{"affected":"2 open source packages ship an affected version, including automad/automad. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-7038 in the wild and no public exploit code.","fix":"Upgrade automad/automad to 2.0.0-alpha.1 or later.","what":"CVE-2023-7038 is a medium-severity vulnerability in automad, published on 21 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-7038 and fix it if it is affected.\n\nWhat it is: CVE-2023-7038 is a medium-severity vulnerability in automad, published on 21 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-7038 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- automad/automad (Packagist): affected all versions; fixed in 2.0.0-alpha.1\n- automad/automad (Packagist): affected all versions; fixed in 2.0.0-alpha.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-7038/ (Markdown: https://insights.sbomify.com/CVE-2023-7038/index.md)","id":"CVE-2023-7038","markdown":"https://insights.sbomify.com/CVE-2023-7038/index.md","name":"CVE-2023-7038","record":{"aliases":["GHSA-4j8w-p6hv-3qxc"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"automad CMS","requires_auth":"none","summary":"Attackers can force authenticated users to create new accounts via cross-site request forgery in automad.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"automad","vendor":"automad"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A vulnerability was found in automad up to 1.10.9. It has been rated as problematic. This issue affects some unknown processing of the file /dashboard?controller=UserCollection::createUser of the component User Creation Handler. The manipulation leads to cross-site request forgery. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-248687. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"automad User Creation cross-site request forgery","id":"CVE-2023-7038","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Byzoro S210 importexport.php injection","id":"CVE-2023-7039"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.0-alpha.1"],"introduced":["0"],"last_affected":[],"package":"automad/automad","purl":null,"source":"GHSA-4j8w-p6hv-3qxc"},{"ecosystem":"Packagist","fixed":["2.0.0-alpha.1"],"introduced":["0"],"last_affected":[],"package":"automad/automad","purl":"pkg:composer/automad/automad","source":"GHSA-4j8w-p6hv-3qxc"}],"prev":{"headline":"automad FileController.php import server-side request forgery","id":"CVE-2023-7037"},"products":["automad"],"published":"2023-12-21","related":[{"cvss_score":8.8,"headline":"Automad arbitrary file upload vulnerability","id":"CVE-2024-40400","kev_date_added":null,"published":"2024-07-19"},{"cvss_score":6.3,"headline":"automad FileController.php import server-side request forgery","id":"CVE-2023-7037","kev_date_added":null,"published":"2023-12-21"},{"cvss_score":5.4,"headline":"Cross site scripting in automad/automad","id":"CVE-2021-37502","kev_date_added":null,"published":"2023-02-03"},{"cvss_score":4.8,"headline":"Cross-site scripting in n/a","id":"CVE-2024-40111","kev_date_added":null,"published":"2024-08-23"},{"cvss_score":4.8,"headline":"automad Setting post.php cross site scripting","id":"CVE-2023-7035","kev_date_added":null,"published":"2023-12-21"},{"cvss_score":4.7,"headline":"automad Content Type FileCollectionController.php upload unrestricted upload","id":"CVE-2023-7036","kev_date_added":null,"published":"2023-12-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can force authenticated users to create new accounts via cross-site request forgery in automad.","url":"https://insights.sbomify.com/CVE-2023-7038/"}