# CVE-2023-7076: slawkens MyAAC bugtracker.php cross site scripting

> Remote attackers can inject malicious scripts via bug tracker inputs in MyAAC, potentially leading to session hijacking or code execution.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 Dec 2023
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-vp88-f5cf-23hj

## What is CVE-2023-7076?

CVE-2023-7076 is a low-severity cross-site scripting vulnerability in slawkens MyAAC, published on 22 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in slawkens MyAAC up to 0.8.13. It has been declared as problematic. This vulnerability affects unknown code of the file system/pages/bugtracker.php. The manipulation of the argument bug[2]['subject']/bug[2]['text']/report['subject'] leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 0.8.14 is able to address this issue. The name of the patch is 83a91ec540072d319dd338abff45f8d5ebf48190. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-248848.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-7076?

It affects 1 product.


Products: My-Aac Myaac.

## How do I fix CVE-2023-7076?

No fix has been published for CVE-2023-7076 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-7076 being exploited?

There is no known exploitation of CVE-2023-7076 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7076 and fix it if it is affected.

What it is: CVE-2023-7076 is a low-severity cross-site scripting vulnerability in slawkens MyAAC, published on 22 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-7076 in the wild and no public exploit code.

Affected product: slawkens MyAAC. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7076/ (Markdown: https://insights.sbomify.com/CVE-2023-7076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7076
- OSV: https://osv.dev/vulnerability/CVE-2023-7076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7076/
Summaries are generated and may contain mistakes; the official description above is the record.
