# CVE-2023-7078: Server-Side Request Forgery (SSRF) in Miniflare

> An attacker on the local network can send arbitrary HTTP and WebSocket requests from the server if Miniflare listens on external interfaces.

- **Severity:** High 7.5 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Dec 2023
- **Updated:** 26 Aug 2024
- **Also known as:** GHSA-fwvg-2739-22v7

## What is CVE-2023-7078?

CVE-2023-7078 is a high-severity server-side request forgery vulnerability in Cloudflare miniflare, published on 29 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Sending specially crafted HTTP requests to Miniflare's server could result in arbitrary HTTP and WebSocket requests being sent from the server. If Miniflare was configured to listen on external network interfaces (as was the default in wrangler until 3.19.0), an attacker on the local network could access other local servers.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-7078?

2 open source packages ship an affected version, including miniflare. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `miniflare` | npm | From 3.20230821.0 | 3.20231030.2 |
| `miniflare` | npm | From 3.20230821.0 | 3.20231030.2 |

Products: Cloudflare Miniflare.

## How do I fix CVE-2023-7078?

Upgrade miniflare to 3.20231030.2 or later.

## Is CVE-2023-7078 being exploited?

There is no known exploitation of CVE-2023-7078 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7078 and fix it if it is affected.

What it is: CVE-2023-7078 is a high-severity server-side request forgery vulnerability in Cloudflare miniflare, published on 29 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-7078 in the wild and no public exploit code.

Affected packages and fixed versions:
- miniflare (npm): affected from 3.20230821.0; fixed in 3.20231030.2
- miniflare (npm): affected from 3.20230821.0; fixed in 3.20231030.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7078/ (Markdown: https://insights.sbomify.com/CVE-2023-7078/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7078
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7078
- OSV: https://osv.dev/vulnerability/CVE-2023-7078

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7078/
Summaries are generated and may contain mistakes; the official description above is the record.
