# CVE-2023-7079: Arbitrary remote file read in Wrangler dev server

> An attacker can read arbitrary files on a developer's machine by sending crafted requests to the Wrangler dev server.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-cfph-4qqh-w828

## What is CVE-2023-7079?

CVE-2023-7079 is a medium-severity path traversal vulnerability in Cloudflare wrangler, published on 29 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Sending specially crafted HTTP requests and inspector messages to Wrangler's dev server could result in any file on the user's computer being accessible over the local network. An attacker that could trick any user on the local network into opening a malicious website could also read any file.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-7079?

2 open source packages ship an affected version, including wrangler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wrangler` | npm | From 3.9.0 | 3.19.0 |
| `wrangler` | npm | From 3.9.0 | 3.19.0 |

Products: Cloudflare Wrangler.

## How do I fix CVE-2023-7079?

Upgrade wrangler to 3.19.0 or later.

## Is CVE-2023-7079 being exploited?

There is no known exploitation of CVE-2023-7079 in the wild and no public exploit code.

## Other vulnerabilities in Cloudflare wrangler

- [CVE-2023-7080](https://insights.sbomify.com/CVE-2023-7080/): Arbitrary remote code execution within wrangler dev Workers sandbox (high 8.5)
- [CVE-2026-0933](https://insights.sbomify.com/CVE-2026-0933/): OS Command Injection in `wrangler pages deploy` (high 7.7)
- [CVE-2023-3348](https://insights.sbomify.com/CVE-2023-3348/): Directory traversal vulnerability in Cloudflare Wrangler (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7079 and fix it if it is affected.

What it is: CVE-2023-7079 is a medium-severity path traversal vulnerability in Cloudflare wrangler, published on 29 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-7079 in the wild and no public exploit code.

Affected packages and fixed versions:
- wrangler (npm): affected from 3.9.0; fixed in 3.19.0
- wrangler (npm): affected from 3.9.0; fixed in 3.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7079/ (Markdown: https://insights.sbomify.com/CVE-2023-7079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7079
- OSV: https://osv.dev/vulnerability/CVE-2023-7079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7079/
Summaries are generated and may contain mistakes; the official description above is the record.
