# CVE-2023-7084: Voting Record <= 2.0 - Subscriber+ Stored XSS

> Authenticated users can inject malicious scripts via the Voting Record plugin, potentially leading to session hijacking or site compromise.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Jan 2024
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-6pww-hfc9-g964

## What is CVE-2023-7084?

CVE-2023-7084 is a medium-severity cross-site scripting vulnerability in Unknown Voting Record, published on 16 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Voting Record WordPress plugin through 2.0 is missing sanitisation as well as escaping, which could allow any authenticated users, such as subscriber to perform Stored XSS attacks

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-7084?

It affects 1 product.


Products: Davidjmiller Voting Record.

## How do I fix CVE-2023-7084?

No fix has been published for CVE-2023-7084 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-7084 being exploited?

There is no known exploitation of CVE-2023-7084 in the wild and no public exploit code.

## Other vulnerabilities in Unknown Voting Record

- [CVE-2023-7083](https://insights.sbomify.com/CVE-2023-7083/): Voting Record <= 2.0 - Settings Update to Stored XSS via CSRF (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7084 and fix it if it is affected.

What it is: CVE-2023-7084 is a medium-severity cross-site scripting vulnerability in Unknown Voting Record, published on 16 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-7084 in the wild and no public exploit code.

Affected product: Unknown Voting Record. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7084/ (Markdown: https://insights.sbomify.com/CVE-2023-7084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7084
- OSV: https://osv.dev/vulnerability/CVE-2023-7084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7084/
Summaries are generated and may contain mistakes; the official description above is the record.
