{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-7093 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-7093 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-7093 is a medium-severity command injection vulnerability in KylinSoft kylin-system-updater, published on 24 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-7093 and fix it if it is affected.\n\nWhat it is: CVE-2023-7093 is a medium-severity command injection vulnerability in KylinSoft kylin-system-updater, published on 24 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-7093 in the wild and no public exploit code.\n\nAffected product: KylinSoft kylin-system-updater. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-7093/ (Markdown: https://insights.sbomify.com/CVE-2023-7093/index.md)","id":"CVE-2023-7093","markdown":"https://insights.sbomify.com/CVE-2023-7093/index.md","name":"CVE-2023-7093","record":{"aliases":["GHSA-q6g2-4gw5-gw53"],"analysis":{"component_type":"operating_system","fix_type":"no_fix_stated","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Kylin system updater","requires_auth":"low_privilege","summary":"Local attackers can execute arbitrary OS commands via the system updater service, potentially escalating privileges on Kylin OS systems.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"kylin-system-updater","vendor":"kylinos"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"A vulnerability classified as critical has been found in KylinSoft kylin-system-updater up to 2.0.5.16-0k2.33. Affected is an unknown function of the file /usr/share/kylin-system-updater/SystemUpdater/UpgradeStrategiesDbus.py of the component com.kylin.systemupgrade Service. The manipulation of the argument SetDownloadspeedMax leads to os command injection. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-248940. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"KylinSoft kylin-system-updater com.kylin.systemupgrade Service UpgradeStrategiesDbus.py os command injection","id":"CVE-2023-7093","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":0,"n_references":3,"next":{"headline":"Netentsec NS-ASG Application Security Gateway nsasg6.0.tgz information disclosure","id":"CVE-2023-7094"},"packages":[],"prev":{"headline":"Uniway UW-302VP Admin Web Interface wlan_basic_set.cgi cross-site request forgery","id":"CVE-2023-7092"},"products":["kylin-system-updater"],"published":"2023-12-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-28","vendors":["KylinSoft"]},"summary":"Local attackers can execute arbitrary OS commands via the system updater service, potentially escalating privileges on Kylin OS systems.","url":"https://insights.sbomify.com/CVE-2023-7093/"}