# CVE-2023-7101: Spreadsheet::ParseExcel Remote Code Execution

> An attacker can execute arbitrary code by crafting a malicious Excel file with specific number format strings, affecting applications using this Perl module.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 2 Jan 2024 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Dec 2023
- **Updated:** 21 Oct 2025
- **Also known as:** DEBIAN-CVE-2023-7101, DLA-3702-1, DSA-5592-1, GHSA-3c85-mx4x-435c, OESA-2025-2507, OESA-2025-2508, OESA-2025-2613, RSEC-2023-9, SUSE-SU-2024:0158-1, UBUNTU-CVE-2023-7101, USN-6781-1, openSUSE-SU-2024:13558-1

## What is CVE-2023-7101?

CVE-2023-7101 is a high-severity code injection vulnerability in Debian Debian Linux, published on 24 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Spreadsheet::ParseExcel version 0.65 is a Perl module used for parsing Excel files. Spreadsheet::ParseExcel is vulnerable to an arbitrary code execution (ACE) vulnerability due to passing unvalidated input from a file into a string-type “eval”. Specifically, the issue stems from the evaluation of Number format strings (not to be confused with printf-style format strings) within the Excel parsing logic.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2023-7101?

1 open source package ship an affected version, including gdata. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gdata` | CRAN | From 2.16.1 | 3.0.0 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Enterprise Storage 7.1 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Real Time 15 SP4 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Manager Proxy 4.3 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | SUSE:Manager Server 4.3 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | openSUSE:Leap 15.5 | All versions | 0.65-150000.3.3.1 |
| `perl-Spreadsheet-ParseExcel` | openSUSE:Tumbleweed | All versions | 0.660.0-1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Jmcnamara Spreadsheet\.

## How do I fix CVE-2023-7101?

Upgrade gdata to 3.0.0 or later. US federal agencies must fix it by 23 Jan 2024.

## Is CVE-2023-7101 being exploited?

Yes. Attackers have exploited CVE-2023-7101 in the wild since at least 2 Jan 2024.

Public exploit code:

- Barracuda ESG Spreadsheet::ParseExcel Arbitrary Code Execution (metasploit)

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7101 and fix it if it is affected.

What it is: CVE-2023-7101 is a high-severity code injection vulnerability in Debian Debian Linux, published on 24 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2023-7101 in the wild since at least 2 Jan 2024.

Affected packages and fixed versions:
- gdata (CRAN): affected from 2.16.1; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7101/ (Markdown: https://insights.sbomify.com/CVE-2023-7101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7101
- OSV: https://osv.dev/vulnerability/CVE-2023-7101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7101/
Summaries are generated and may contain mistakes; the official description above is the record.
