# CVE-2023-7113: Mattermost Cross-site Scripting vulnerability

> Attackers can inject malicious markup into channel mentions, potentially executing scripts in the web client to compromise user accounts.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-mattermost-2023-7113, GHSA-h3gq-j7p9-x3p4, GO-2024-2446

## What is CVE-2023-7113?

CVE-2023-7113 is a low-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 29 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mattermost version 8.1.6 and earlier fails to sanitize channel mention data in posts, which allows an attacker to inject markup in the web client.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-7113?

7 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.1.7 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.1.7 |
| `mattermost` | Bitnami | All versions | 8.1.7 |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2023-7113?

Upgrade github.com/mattermost/mattermost/server/v8 to 8.1.7 or later.

## Is CVE-2023-7113 being exploited?

There is no known exploitation of CVE-2023-7113 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7113 and fix it if it is affected.

What it is: CVE-2023-7113 is a low-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 29 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-7113 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.1.7
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.1.7
- mattermost (Bitnami): affected all versions; fixed in 8.1.7
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7113/ (Markdown: https://insights.sbomify.com/CVE-2023-7113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7113
- OSV: https://osv.dev/vulnerability/CVE-2023-7113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7113/
Summaries are generated and may contain mistakes; the official description above is the record.
