{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-7158 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-7158 is a high-severity memory corruption vulnerability in MicroPython, published on 29 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-7158 and fix it if it is affected.\n\nWhat it is: CVE-2023-7158 is a high-severity memory corruption vulnerability in MicroPython, published on 29 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-7158 in the wild and no public exploit code.\n\nAffected product: MicroPython. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-7158/ (Markdown: https://insights.sbomify.com/CVE-2023-7158/index.md)","id":"CVE-2023-7158","markdown":"https://insights.sbomify.com/CVE-2023-7158/index.md","name":"CVE-2023-7158","record":{"aliases":["GHSA-x33q-m927-7mq6","UBUNTU-CVE-2023-7158","openSUSE-SU-2024:13566-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MicroPython library","requires_auth":"none","summary":"A heap-based buffer overflow in MicroPython allows remote attackers to execute arbitrary code or cause denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"micropython","vendor":"micropython"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MicroPython objslice.c slice_indices heap-based overflow","id":"CVE-2023-7158","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":1,"n_references":9,"next":{"headline":"gopeak MasterLab User.php update unrestricted upload","id":"CVE-2023-7159"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.22.0-1.1"],"introduced":["0"],"last_affected":[],"package":"micropython","purl":"pkg:rpm/opensuse/micropython\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13566-1"}],"prev":{"headline":"SourceCodester Free and Open Source Inventory Management System sell_return_data.php sql injection","id":"CVE-2023-7157"},"products":["MicroPython"],"published":"2023-12-29","related":[{"cvss_score":6.9,"headline":"MicroPython VFS Unmount vfs.c mp_vfs_umount heap-based overflow","id":"CVE-2024-8946","kev_date_added":null,"published":"2024-09-17"},{"cvss_score":6.9,"headline":"MicroPython objint.c mpz_as_bytes heap-based overflow","id":"CVE-2024-8948","kev_date_added":null,"published":"2024-09-17"},{"cvss_score":6.3,"headline":"MicroPython objarray.c use after free","id":"CVE-2024-8947","kev_date_added":null,"published":"2024-09-17"},{"cvss_score":5.5,"headline":"MicroPython modselect.c poll_set_add_fd use after free","id":"CVE-2023-7152","kev_date_added":null,"published":"2023-12-29"},{"cvss_score":4.8,"headline":"micropython runtime.c mp_import_all memory corruption","id":"CVE-2026-1998","kev_date_added":null,"published":"2026-02-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["n/a"]},"summary":"A heap-based buffer overflow in MicroPython allows remote attackers to execute arbitrary code or cause denial of service.","url":"https://insights.sbomify.com/CVE-2023-7158/"}