# CVE-2023-7158: MicroPython objslice.c slice_indices heap-based overflow

> A heap-based buffer overflow in MicroPython allows remote attackers to execute arbitrary code or cause denial of service.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Dec 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-x33q-m927-7mq6, UBUNTU-CVE-2023-7158, openSUSE-SU-2024:13566-1

## What is CVE-2023-7158?

CVE-2023-7158 is a high-severity memory corruption vulnerability in MicroPython, published on 29 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2023-7158?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `micropython` | openSUSE:Tumbleweed | All versions | 1.22.0-1.1 |

Products: Micropython Micropython.

## How do I fix CVE-2023-7158?

Upgrade to a fixed version.

## Is CVE-2023-7158 being exploited?

There is no known exploitation of CVE-2023-7158 in the wild and no public exploit code.

## Other vulnerabilities in MicroPython

- [CVE-2024-8946](https://insights.sbomify.com/CVE-2024-8946/): MicroPython VFS Unmount vfs.c mp_vfs_umount heap-based overflow (medium 6.9)
- [CVE-2024-8948](https://insights.sbomify.com/CVE-2024-8948/): MicroPython objint.c mpz_as_bytes heap-based overflow (medium 6.9)
- [CVE-2024-8947](https://insights.sbomify.com/CVE-2024-8947/): MicroPython objarray.c use after free (medium 6.3)
- [CVE-2023-7152](https://insights.sbomify.com/CVE-2023-7152/): MicroPython modselect.c poll_set_add_fd use after free (medium 5.5)
- [CVE-2026-1998](https://insights.sbomify.com/CVE-2026-1998/): micropython runtime.c mp_import_all memory corruption (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7158 and fix it if it is affected.

What it is: CVE-2023-7158 is a high-severity memory corruption vulnerability in MicroPython, published on 29 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-7158 in the wild and no public exploit code.

Affected product: MicroPython. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7158/ (Markdown: https://insights.sbomify.com/CVE-2023-7158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7158
- OSV: https://osv.dev/vulnerability/CVE-2023-7158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7158/
Summaries are generated and may contain mistakes; the official description above is the record.
