# CVE-2023-7231: illi Link Party! <= 1.0 - Unauthenticated Arbitrary Link Deletion

> Unauthenticated attackers can delete arbitrary links in the illi Link Party! WordPress plugin due to missing access controls.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 May 2025
- **Updated:** 16 May 2025
- **Also known as:** GHSA-c44h-wf4g-24fr

## What is CVE-2023-7231?

CVE-2023-7231 is a high-severity missing authorization vulnerability in Unknown illi Link Party!, published on 15 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The illi Link Party! WordPress plugin through 1.0 lacks proper access controls, allowing unauthenticated visitors to delete links.

## Which versions are affected by CVE-2023-7231?

It affects 1 product.


Products: Evanliewer Illi Link Party\!.

## How do I fix CVE-2023-7231?

No fix has been published for CVE-2023-7231 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-7231 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-7231 exists.

Public exploit code:

- PoC and Disclosure for CVE-2023-7231 – Memcached Gopher RCE chain (github_poc): https://github.com/BBO513/CVE-2023-7231

## Other vulnerabilities in Unknown illi Link Party!

- [CVE-2023-7228](https://insights.sbomify.com/CVE-2023-7228/): illi Link Party! <= 1.0 - Unauthenticated Stored XSS (medium 6.1)
- [CVE-2023-7230](https://insights.sbomify.com/CVE-2023-7230/): illi Link Party! <= 1.0 - Admin+ Stored Cross-Site Scripting (medium 6.1)
- [CVE-2023-7229](https://insights.sbomify.com/CVE-2023-7229/): illi Link Party! <= 1.0 - Settings Update via CSRF (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7231 and fix it if it is affected.

What it is: CVE-2023-7231 is a high-severity missing authorization vulnerability in Unknown illi Link Party!, published on 15 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-7231 exists.

Affected product: Unknown illi Link Party!. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7231/ (Markdown: https://insights.sbomify.com/CVE-2023-7231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7231
- OSV: https://osv.dev/vulnerability/CVE-2023-7231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7231/
Summaries are generated and may contain mistakes; the official description above is the record.
