CVE-2023-7272 Eclipse Parsson stack overflow with deeply nested objects
Attackers can cause denial of service in applications using Eclipse Parsson by submitting deeply nested JSON objects, triggering a stack overflow.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-7272?
CVE-2023-7272 is a high-severity denial of service vulnerability in Eclipse Foundation Parsson, published on 17 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Eclipse Parsson before 1.0.4 and 1.1.3, a document with a large depth of nested objects can allow an attacker to cause a Java stack overflow exception and denial of service. Eclipse Parsson allows processing (e.g. parse, generate, transform and query) JSON documents.
Weakness: CWE-787
Which versions are affected by CVE-2023-7272?
4 open source packages ship an affected version, including org.eclipse.parsson:parsson. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.eclipse.parsson:parsson Maven | All versions | 1.0.4 |
org.eclipse.parsson:parsson Maven | All versions | 1.0.4 |
org.eclipse.parsson:parsson Maven | From 1.1.0 | 1.1.3 |
org.eclipse.parsson:parsson Maven | From 1.1.0 | 1.1.3 |
Products include Eclipse Parsson.
How do I fix CVE-2023-7272?
Upgrade org.eclipse.parsson:parsson to a fixed version for your release line: 1.0.4 or 1.1.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-7272 being exploited?
There is no known exploitation of CVE-2023-7272 in the wild and no public exploit code.
Other vulnerabilities in Eclipse Foundation Parsson
Sources
Also known as GHSA-2rwm-xv5j-777p.