{"answers":{"affected":"2 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2023-7332 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to 4.18.1 or later.","what":"CVE-2023-7332 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 31 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-7332 and fix it if it is affected.\n\nWhat it is: CVE-2023-7332 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 31 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-7332 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.18.1\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-7332/ (Markdown: https://insights.sbomify.com/CVE-2023-7332/index.md)","id":"CVE-2023-7332","markdown":"https://insights.sbomify.com/CVE-2023-7332/index.md","name":"CVE-2023-7332","record":{"aliases":["GHSA-h87r-f4vc-mchv"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft server software","requires_auth":"low_privilege","summary":"A remote attacker with a valid session can crash the PocketMine-MP server by requesting invalid item drops, causing denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"}],"description":"PocketMine-MP versions prior to 4.18.1 contain an improper input validation vulnerability in inventory transaction handling. A remote attacker with a valid player session can request that the server drop more items than are available in the player's hotbar, triggering a server crash and resulting in denial of service.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PocketMine-MP \u003c 4.18.1 Improper Validation of Dropped Item Count Allows Remote Server Crash","id":"CVE-2023-7332","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"bluelabsio records-mover Table Object sql injection","id":"CVE-2023-7333"},"packages":[{"ecosystem":"Packagist","fixed":["4.18.1"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-h87r-f4vc-mchv"},{"ecosystem":"Packagist","fixed":["4.18.1"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-h87r-f4vc-mchv"}],"prev":{"headline":"PKrystian Full-Stack-Bank User sql injection","id":"CVE-2023-7331"},"products":["PocketMine-MP"],"published":"2025-12-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":"A remote attacker with a valid session can crash the PocketMine-MP server by requesting invalid item drops, causing denial of service.","url":"https://insights.sbomify.com/CVE-2023-7332/"}