# CVE-2023-7332: PocketMine-MP < 4.18.1 Improper Validation of Dropped Item Count Allows Remote Server Crash

> A remote attacker with a valid session can crash the PocketMine-MP server by requesting invalid item drops, causing denial of service.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2025
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-h87r-f4vc-mchv

## What is CVE-2023-7332?

CVE-2023-7332 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 31 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PocketMine-MP versions prior to 4.18.1 contain an improper input validation vulnerability in inventory transaction handling. A remote attacker with a valid player session can request that the server drop more items than are available in the player's hotbar, triggering a server crash and resulting in denial of service.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2023-7332?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.18.1 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.18.1 |

## How do I fix CVE-2023-7332?

Upgrade pocketmine/pocketmine-mp to 4.18.1 or later.

## Is CVE-2023-7332 being exploited?

There is no known exploitation of CVE-2023-7332 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7332 and fix it if it is affected.

What it is: CVE-2023-7332 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 31 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-7332 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.18.1
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7332/ (Markdown: https://insights.sbomify.com/CVE-2023-7332/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7332
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7332
- OSV: https://osv.dev/vulnerability/CVE-2023-7332

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7332/
Summaries are generated and may contain mistakes; the official description above is the record.
