# CVE-2023-7333: bluelabsio records-mover Table Object sql injection


- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jan 2026
- **Updated:** 23 Feb 2026
- **Also known as:** GHSA-p3jp-7gj7-h6pr, PYSEC-2026-1864

## What is CVE-2023-7333?

CVE-2023-7333 is a medium-severity vulnerability in bluelabsio records-mover, published on 7 Jan 2026. 

### Official description

A weakness has been identified in bluelabsio records-mover up to 1.5.4. The affected element is an unknown function of the component Table Object Handler. This manipulation causes sql injection. The attack needs to be launched locally. Upgrading to version 1.6.0 is sufficient to fix this issue. Patch name: 3f8383aa89f45d861ca081e3e9fd2cc9d0b5dfaa. You should upgrade the affected component.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-7333?

3 open source packages ship an affected version, including records-mover.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `records-mover` | PyPI | All versions | 1.6.0 |
| `records-mover` | PyPI | All versions | 1.6.0 |
| `records-mover` | PyPI | All versions | 1.6.0 |

## How do I fix CVE-2023-7333?

Upgrade records-mover to 1.6.0 or later.

## Is CVE-2023-7333 being exploited?

There is no known exploitation of CVE-2023-7333 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-7333 and fix it if it is affected.

What it is: CVE-2023-7333 is a medium-severity vulnerability in bluelabsio records-mover, published on 7 Jan 2026. 
Exploitation: There is no known exploitation of CVE-2023-7333 in the wild and no public exploit code.

Affected packages and fixed versions:
- records-mover (PyPI): affected all versions; fixed in 1.6.0
- records-mover (PyPI): affected all versions; fixed in 1.6.0
- records-mover (PyPI): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-7333/ (Markdown: https://insights.sbomify.com/CVE-2023-7333/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-7333
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-7333
- OSV: https://osv.dev/vulnerability/CVE-2023-7333

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-7333/
Summaries are generated and may contain mistakes; the official description above is the record.
