# CVE-2024-0132: NVIDIA Container Toolkit contains a Time-of-check Time-of-Use (TOCTOU) vulnerability

> Attackers can exploit a race condition in NVIDIA Container Toolkit to escape containers and execute code on the host system.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2024
- **Updated:** 27 Sep 2024
- **Also known as:** AZL-50160, AZL-50180, GHSA-mjjw-553x-87pq, GO-2024-3239

## What is CVE-2024-0132?

CVE-2024-0132 is a critical vulnerability in NVIDIA Container Toolkit, published on 26 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

NVIDIA Container Toolkit 1.16.1 or earlier contains a Time-of-check Time-of-Use (TOCTOU) vulnerability when used with default configuration where a specifically crafted container image may gain access to the host file system. This does not impact use cases where CDI is used. A successful exploit of this vulnerability may lead to code execution, denial of service, escalation of privileges, information disclosure, and data tampering.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2024-0132?

3 open source packages ship an affected version, including github.com/NVIDIA/nvidia-container-toolkit. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/NVIDIA/nvidia-container-toolkit` | Go | All versions | 1.16.2 |
| `github.com/NVIDIA/nvidia-container-toolkit` | Go | All versions | 1.16.2 |
| `github.com/NVIDIA/nvidia-container-toolkit` | Go | All versions | 1.16.2 |

Products: Nvidia Nvidia Container Toolkit, Nvidia Nvidia Gpu Operator.

## How do I fix CVE-2024-0132?

Upgrade github.com/NVIDIA/nvidia-container-toolkit to 1.16.2 or later.

## Is CVE-2024-0132 being exploited?

There is no known exploitation of CVE-2024-0132 in the wild and no public exploit code.

Public exploit code:

- CVE-2024-0132 – Fully Weaponized NVIDIA Container Toolkit Exploit (github_poc): https://github.com/r0binak/CVE-2024-0132
- https://github.com/ssst0n3/poc-cve-2024-0132 (github_poc): https://github.com/ssst0n3/poc-cve-2024-0132
- NVIDIA Container Toolkit 1.16.1 - Time-of-check Time-of-Use (TOCTOU) (exploitdb)

## Other vulnerabilities in NVIDIA Container Toolkit

- [CVE-2025-23359](https://insights.sbomify.com/CVE-2025-23359/): Race condition in Container Toolkit (high 8.3)
- [CVE-2024-0135](https://insights.sbomify.com/CVE-2024-0135/): Privilege escalation in NVIDIA Container Toolkit (high 7.6)
- [CVE-2024-0136](https://insights.sbomify.com/CVE-2024-0136/): Privilege escalation in NVIDIA Container Toolkit (high 7.6)
- [CVE-2024-0137](https://insights.sbomify.com/CVE-2024-0137/): Privilege escalation in NVIDIA Container Toolkit (medium 5.5)
- [CVE-2024-0134](https://insights.sbomify.com/CVE-2024-0134/): Path traversal in NVIDIA Container Toolkit (medium 4.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0132 and fix it if it is affected.

What it is: CVE-2024-0132 is a critical vulnerability in NVIDIA Container Toolkit, published on 26 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-0132 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/NVIDIA/nvidia-container-toolkit (Go): affected all versions; fixed in 1.16.2
- github.com/NVIDIA/nvidia-container-toolkit (Go): affected all versions; fixed in 1.16.2
- github.com/NVIDIA/nvidia-container-toolkit (Go): affected all versions; fixed in 1.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0132/ (Markdown: https://insights.sbomify.com/CVE-2024-0132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0132
- OSV: https://osv.dev/vulnerability/CVE-2024-0132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0132/
Summaries are generated and may contain mistakes; the official description above is the record.
