CVE-2024-0199 Incorrect Authorization in GitLab

High 7.7 Published Updated

An attacker can bypass CODEOWNERS restrictions in GitLab to perform unauthorized actions on feature branches.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-0199?

CVE-2024-0199 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 7 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An authorization bypass vulnerability was discovered in GitLab affecting versions 11.3 prior to 16.7.7, 16.7.6 prior to 16.8.4, and 16.8.3 prior to 16.9.2. An attacker could bypass CODEOWNERS by utilizing a crafted payload in an old feature branch to perform malicious actions.

Weakness: CWE-863

Which versions are affected by CVE-2024-0199?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.3.016.7.7, 16.8.4, 16.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-0199?

Upgrade gitlab to a fixed version for your release line: 16.7.7, 16.8.4 or 16.9.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-0199 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0199 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-0199, GHSA-rhx5-h5p6-9g65, UBUNTU-CVE-2024-0199.

Is CVE-2024-0199 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free