# CVE-2024-0199: Incorrect Authorization in GitLab

> An attacker can bypass CODEOWNERS restrictions in GitLab to perform unauthorized actions on feature branches.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2024
- **Updated:** 16 Apr 2025
- **Also known as:** BIT-gitlab-2024-0199, GHSA-rhx5-h5p6-9g65, UBUNTU-CVE-2024-0199

## What is CVE-2024-0199?

CVE-2024-0199 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 7 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An authorization bypass vulnerability was discovered in GitLab affecting versions 11.3 prior to 16.7.7, 16.7.6 prior to 16.8.4, and 16.8.3 prior to 16.9.2. An attacker could bypass CODEOWNERS by utilizing a crafted payload in an old feature branch to perform malicious actions.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-0199?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 11.3.0 | 16.7.7, 16.8.4, 16.9.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-0199?

Upgrade gitlab to a fixed version for your release line: 16.7.7, 16.8.4 or 16.9.2.

## Is CVE-2024-0199 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0199 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0199 and fix it if it is affected.

What it is: CVE-2024-0199 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 7 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0199 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 11.3.0; fixed in 16.7.7, 16.8.4, 16.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0199/ (Markdown: https://insights.sbomify.com/CVE-2024-0199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0199
- OSV: https://osv.dev/vulnerability/CVE-2024-0199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0199/
Summaries are generated and may contain mistakes; the official description above is the record.
