CVE-2024-0200 Unsafe Reflection in Github Enterprise Server leading to Command Injection

High 7.2 Published Updated

An organization owner can exploit unsafe reflection to execute arbitrary code on GitHub Enterprise Server instances.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-0200?

CVE-2024-0200 is a high-severity code injection vulnerability in Github Enterprise Server, published on 16 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An unsafe reflection vulnerability was identified in GitHub Enterprise Server that could lead to reflection injection. This vulnerability could lead to the execution of user-controlled methods and remote code execution. To exploit this bug, an actor would need to be logged into an account on the GHES instance with the organization owner role. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in versions 3.8.13, 3.9.8, 3.10.5, and 3.11.3. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-470

Which versions are affected by CVE-2024-0200?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2024-0200?

No fix has been published for CVE-2024-0200 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-0200 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0200 exists.

Public exploit code: 1 Nuclei template.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-g39r-hh73-78xj.

Is CVE-2024-0200 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free