CVE-2024-0231 Improper Control of Resource Identifiers ('Resource Injection') in GitLab

Low 2.7 Published Updated

An attacker can craft a repository import to misdirect commits, potentially altering code history in GitLab instances.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-0231?

CVE-2024-0231 is a low-severity vulnerability in Gitlab Gitlab, published on 24 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A resource misdirection vulnerability in GitLab CE/EE versions 12.0 prior to 17.0.5, 17.1 prior to 17.1.3, and 17.2 prior to 17.2.1 allows an attacker to craft a repository import in such a way as to misdirect commits.

Weakness: CWE-74, CWE-99

Which versions are affected by CVE-2024-0231?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.0.017.0.5, 17.1.3, 17.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-0231?

Upgrade gitlab to a fixed version for your release line: 17.0.5, 17.1.3 or 17.2.1.

Is CVE-2024-0231 being exploited?

There is no known exploitation of CVE-2024-0231 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-0231, GHSA-9jp8-rx43-82gm, UBUNTU-CVE-2024-0231.

Is CVE-2024-0231 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free