{"answers":{"affected":"2 open source packages ship an affected version, including encoded_id-rails. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0241 exists.","fix":"Upgrade encoded_id-rails to 1.0.0.beta2 or later.","what":"CVE-2024-0241 is a high-severity denial of service vulnerability in diaconou:encodedid\\, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-0241 and fix it if it is affected.\n\nWhat it is: CVE-2024-0241 is a high-severity denial of service vulnerability in diaconou:encodedid\\, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0241 exists.\n\nAffected packages and fixed versions:\n- encoded_id-rails (RubyGems): affected all versions; fixed in 1.0.0.beta2\n- encoded_id-rails (RubyGems): affected all versions; fixed in 1.0.0.beta2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-0241/ (Markdown: https://insights.sbomify.com/CVE-2024-0241/index.md)","id":"CVE-2024-0241","markdown":"https://insights.sbomify.com/CVE-2024-0241/index.md","name":"CVE-2024-0241","record":{"aliases":["GHSA-3px7-jm2p-6h2c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails library","requires_auth":"none","summary":"Remote attackers can cause denial of service by sending requests with extremely long ID parameters in the encoded_id-rails library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"encodedid\\","vendor":"diaconou"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"encoded_id-rails versions before 1.0.0.beta2 are affected by an uncontrolled resource consumption vulnerability. A remote and unauthenticated attacker might cause a denial of service condition by sending an HTTP request with an extremely long \"id\" parameter.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"encoded_id-rails Denial of Service Vulnerability","id":"CVE-2024-0241","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"Unauthorized access to settings in Qolsys IQ Panel 4 and IQ4 Hub","id":"CVE-2024-0242"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.0.beta2"],"introduced":["0"],"last_affected":[],"package":"encoded_id-rails","purl":null,"source":"GHSA-3px7-jm2p-6h2c"},{"ecosystem":"RubyGems","fixed":["1.0.0.beta2"],"introduced":["0"],"last_affected":[],"package":"encoded_id-rails","purl":"pkg:gem/encoded_id-rails","source":"GHSA-3px7-jm2p-6h2c"}],"prev":{"headline":"Silicon Labs EFR32 Bluetooth stack denial of service when sending notifications to multiple clients","id":"CVE-2024-0240"},"products":["diaconou:encodedid\\"],"published":"2024-01-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["diaconou"]},"summary":"Remote attackers can cause denial of service by sending requests with extremely long ID parameters in the encoded_id-rails library.","url":"https://insights.sbomify.com/CVE-2024-0241/"}