# CVE-2024-0241: encoded_id-rails Denial of Service Vulnerability

> Remote attackers can cause denial of service by sending requests with extremely long ID parameters in the encoded_id-rails library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2024
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-3px7-jm2p-6h2c

## What is CVE-2024-0241?

CVE-2024-0241 is a high-severity denial of service vulnerability in diaconou:encodedid\, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

encoded_id-rails versions before 1.0.0.beta2 are affected by an uncontrolled resource consumption vulnerability. A remote and unauthenticated attacker might cause a denial of service condition by sending an HTTP request with an extremely long "id" parameter.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-0241?

2 open source packages ship an affected version, including encoded_id-rails. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `encoded_id-rails` | RubyGems | All versions | 1.0.0.beta2 |
| `encoded_id-rails` | RubyGems | All versions | 1.0.0.beta2 |

Products: Diaconou Encodedid\.

## How do I fix CVE-2024-0241?

Upgrade encoded_id-rails to 1.0.0.beta2 or later.

## Is CVE-2024-0241 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0241 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0241 and fix it if it is affected.

What it is: CVE-2024-0241 is a high-severity denial of service vulnerability in diaconou:encodedid\, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0241 exists.

Affected packages and fixed versions:
- encoded_id-rails (RubyGems): affected all versions; fixed in 1.0.0.beta2
- encoded_id-rails (RubyGems): affected all versions; fixed in 1.0.0.beta2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0241/ (Markdown: https://insights.sbomify.com/CVE-2024-0241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0241
- OSV: https://osv.dev/vulnerability/CVE-2024-0241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0241/
Summaries are generated and may contain mistakes; the official description above is the record.
