CVE-2024-0248 EazyDocs < 2.4.0 - Subscriber+ Arbitrary Posts Deletion and Document Management
Authenticated subscribers can delete arbitrary posts and manage documents due to missing authorization checks in the EazyDocs WordPress plugin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-0248?
CVE-2024-0248 is a medium-severity missing authorization vulnerability in Unknown EazyDocs, published on 12 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The EazyDocs WordPress plugin before 2.4.0 re-introduced CVE-2023-6029 (https://wpscan.com/vulnerability/7a0aaf85-8130-4fd7-8f09-f8edc929597e/) in 2.3.8, allowing any authenticated users, such as subscriber to delete arbitrary posts, as well as add and delete documents/sections. The issue was partially fixed in 2.3.9.
Which versions are affected by CVE-2024-0248?
It affects 1 product.
Products include Spider-Themes Eazydocs.
How do I fix CVE-2024-0248?
No fix has been published for CVE-2024-0248 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-0248 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0248 exists.
Other vulnerabilities in Unknown EazyDocs
Sources
Also known as GHSA-xmp6-3vj6-r6rw.