{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0248 exists.","fix":"No fix has been published for CVE-2024-0248 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-0248 is a medium-severity missing authorization vulnerability in Unknown EazyDocs, published on 12 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-0248 and fix it if it is affected.\n\nWhat it is: CVE-2024-0248 is a medium-severity missing authorization vulnerability in Unknown EazyDocs, published on 12 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0248 exists.\n\nAffected product: Unknown EazyDocs. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-0248/ (Markdown: https://insights.sbomify.com/CVE-2024-0248/index.md)","id":"CVE-2024-0248","markdown":"https://insights.sbomify.com/CVE-2024-0248/index.md","name":"CVE-2024-0248","record":{"aliases":["GHSA-xmp6-3vj6-r6rw"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can delete arbitrary posts and manage documents due to missing authorization checks in the EazyDocs WordPress plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[{"product":"eazydocs","vendor":"spider-themes"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[],"description":"The EazyDocs WordPress plugin before 2.4.0 re-introduced CVE-2023-6029 (https://wpscan.com/vulnerability/7a0aaf85-8130-4fd7-8f09-f8edc929597e/) in 2.3.8, allowing any authenticated users, such as subscriber to delete arbitrary posts, as well as add and delete documents/sections. The issue was partially fixed in 2.3.9.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"EazyDocs \u003c 2.4.0 - Subscriber+ Arbitrary Posts Deletion and Document Management","id":"CVE-2024-0248","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":0,"n_references":1,"next":{"headline":"Advanced Schedule Posts \u003c= 2.1.8 - Reflected XSS","id":"CVE-2024-0249"},"packages":[],"prev":{"headline":"CodeAstro Online Food Ordering System Admin Panel sql injection","id":"CVE-2024-0247"},"products":["EazyDocs"],"published":"2024-02-12","related":[{"cvss_score":8.8,"headline":"EazyDocs \u003c 2.3.4 - Subscriber + SQLi","id":"CVE-2023-6035","kev_date_added":null,"published":"2023-12-11"},{"cvss_score":7.5,"headline":"EazyDocs \u003c 2.3.6 - Unauthenticated Arbitrary Posts Deletion and Document Management","id":"CVE-2023-6029","kev_date_added":null,"published":"2024-01-15"},{"cvss_score":6.8,"headline":"WordPress EazyDocs Plugin \u003c= 2.3.3 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-47549","kev_date_added":null,"published":"2023-11-14"},{"cvss_score":4.8,"headline":"EazyDocs \u003c 2.5.0 - Admin+ Stored XSS","id":"CVE-2024-3999","kev_date_added":null,"published":"2024-07-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-07","vendors":["Unknown"]},"summary":"Authenticated subscribers can delete arbitrary posts and manage documents due to missing authorization checks in the EazyDocs WordPress plugin.","url":"https://insights.sbomify.com/CVE-2024-0248/"}