# CVE-2024-0248: EazyDocs < 2.4.0 - Subscriber+ Arbitrary Posts Deletion and Document Management

> Authenticated subscribers can delete arbitrary posts and manage documents due to missing authorization checks in the EazyDocs WordPress plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2024
- **Updated:** 7 May 2025
- **Also known as:** GHSA-xmp6-3vj6-r6rw

## What is CVE-2024-0248?

CVE-2024-0248 is a medium-severity missing authorization vulnerability in Unknown EazyDocs, published on 12 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The EazyDocs WordPress plugin before 2.4.0 re-introduced CVE-2023-6029 (https://wpscan.com/vulnerability/7a0aaf85-8130-4fd7-8f09-f8edc929597e/) in 2.3.8, allowing any authenticated users, such as subscriber to delete arbitrary posts, as well as add and delete documents/sections. The issue was partially fixed in 2.3.9.

## Which versions are affected by CVE-2024-0248?

It affects 1 product.


Products: Spider-Themes Eazydocs.

## How do I fix CVE-2024-0248?

No fix has been published for CVE-2024-0248 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-0248 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0248 exists.

## Other vulnerabilities in Unknown EazyDocs

- [CVE-2023-6035](https://insights.sbomify.com/CVE-2023-6035/): EazyDocs < 2.3.4 - Subscriber + SQLi (high 8.8)
- [CVE-2023-6029](https://insights.sbomify.com/CVE-2023-6029/): EazyDocs < 2.3.6 - Unauthenticated Arbitrary Posts Deletion and Document Management (high 7.5)
- [CVE-2023-47549](https://insights.sbomify.com/CVE-2023-47549/): WordPress EazyDocs Plugin <= 2.3.3 is vulnerable to Cross Site Scripting (XSS) (medium 6.8)
- [CVE-2024-3999](https://insights.sbomify.com/CVE-2024-3999/): EazyDocs < 2.5.0 - Admin+ Stored XSS (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0248 and fix it if it is affected.

What it is: CVE-2024-0248 is a medium-severity missing authorization vulnerability in Unknown EazyDocs, published on 12 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0248 exists.

Affected product: Unknown EazyDocs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0248/ (Markdown: https://insights.sbomify.com/CVE-2024-0248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0248
- OSV: https://osv.dev/vulnerability/CVE-2024-0248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0248/
Summaries are generated and may contain mistakes; the official description above is the record.
