{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0394 exists.","fix":"No fix has been published for CVE-2024-0394 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-0394 is a high-severity vulnerability in Rapid7 Minerva, published on 3 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-0394 and fix it if it is affected.\n\nWhat it is: CVE-2024-0394 is a high-severity vulnerability in Rapid7 Minerva, published on 3 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0394 exists.\n\nAffected product: Rapid7 Minerva. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-0394/ (Markdown: https://insights.sbomify.com/CVE-2024-0394/index.md)","id":"CVE-2024-0394","markdown":"https://insights.sbomify.com/CVE-2024-0394/index.md","name":"CVE-2024-0394","record":{"aliases":["GHSA-5q37-x55w-w66j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rapid7 Minerva Armor","requires_auth":"low_privilege","summary":"An authenticated attacker can elevate privileges to SYSTEM and execute arbitrary code due to insecure OpenSSL directory permissions.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"rapid7","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Rapid7 Minerva Armor versions below 4.5.5 suffer from a privilege escalation vulnerability whereby an authenticated attacker can elevate privileges and execute arbitrary code with SYSTEM privilege.  The vulnerability is caused by the product's implementation of OpenSSL's`OPENSSLDIR` parameter where it is set to a path accessible to low-privileged users.  The vulnerability has been remediated and fixed in version 4.5.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Rapid7 Minerva Armor Privilege Escalation","id":"CVE-2024-0394","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":0,"n_references":1,"next":{"headline":"NON Security Issue.","id":"CVE-2024-0395"},"packages":[],"prev":{"headline":"This CVE ID was unused by the CNA.","id":"CVE-2024-0393"},"products":["Minerva"],"published":"2024-04-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-22","vendors":["Rapid7"]},"summary":"An authenticated attacker can elevate privileges to SYSTEM and execute arbitrary code due to insecure OpenSSL directory permissions.","url":"https://insights.sbomify.com/CVE-2024-0394/"}