# CVE-2024-0394: Rapid7 Minerva Armor Privilege Escalation

> An authenticated attacker can elevate privileges to SYSTEM and execute arbitrary code due to insecure OpenSSL directory permissions.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Apr 2024
- **Updated:** 22 Aug 2024
- **Also known as:** GHSA-5q37-x55w-w66j

## What is CVE-2024-0394?

CVE-2024-0394 is a high-severity vulnerability in Rapid7 Minerva, published on 3 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Rapid7 Minerva Armor versions below 4.5.5 suffer from a privilege escalation vulnerability whereby an authenticated attacker can elevate privileges and execute arbitrary code with SYSTEM privilege.  The vulnerability is caused by the product's implementation of OpenSSL's`OPENSSLDIR` parameter where it is set to a path accessible to low-privileged users.  The vulnerability has been remediated and fixed in version 4.5.5.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-0394?


## How do I fix CVE-2024-0394?

No fix has been published for CVE-2024-0394 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-0394 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0394 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0394 and fix it if it is affected.

What it is: CVE-2024-0394 is a high-severity vulnerability in Rapid7 Minerva, published on 3 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0394 exists.

Affected product: Rapid7 Minerva. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0394/ (Markdown: https://insights.sbomify.com/CVE-2024-0394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0394
- OSV: https://osv.dev/vulnerability/CVE-2024-0394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0394/
Summaries are generated and may contain mistakes; the official description above is the record.
