CVE-2024-0410 Improper Enforcement of Behavioral Workflow in GitLab

High 7.7 Published Updated

A developer can bypass CODEOWNERS approval requirements by creating a merge conflict, allowing unauthorized code changes.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-0410?

CVE-2024-0410 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 21 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An authorization bypass vulnerability was discovered in GitLab affecting versions 15.1 prior to 16.7.6, 16.8 prior to 16.8.3, and 16.9 prior to 16.9.1. A developer could bypass CODEOWNERS approvals by creating a merge conflict.

Weakness: CWE-841

Which versions are affected by CVE-2024-0410?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.1.016.7.6, 16.8.3, 16.9.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-0410?

Upgrade gitlab to a fixed version for your release line: 16.7.6, 16.8.3 or 16.9.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-0410 being exploited?

There is no known exploitation of CVE-2024-0410 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-0410, GHSA-27r2-6rqh-xrg8, UBUNTU-CVE-2024-0410.

Is CVE-2024-0410 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free