CVE-2024-0456 Direct Request ('Forced Browsing') in GitLab

Medium 4.3 Published Updated

An unauthorized attacker can assign arbitrary users to merge requests they created, allowing for data modification within the project.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-0456?

CVE-2024-0456 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 26 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authorization vulnerability exists in GitLab versions 14.0 prior to 16.6.6, 16.7 prior to 16.7.4, and 16.8 prior to 16.8.1. An unauthorized attacker is able to assign arbitrary users to MRs that they created within the project

Weakness: CWE-425

Which versions are affected by CVE-2024-0456?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.0.016.6.6, 16.7.4, 16.8.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-0456?

Upgrade gitlab to a fixed version for your release line: 16.6.6, 16.7.4 or 16.8.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-0456 being exploited?

There is no known exploitation of CVE-2024-0456 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-0456, GHSA-mr56-56j8-x6r4, UBUNTU-CVE-2024-0456.

Is CVE-2024-0456 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free