# CVE-2024-0521: Code Injection in paddlepaddle/paddle


- **Severity:** Critical 9.3 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Jan 2024
- **Updated:** 30 May 2025
- **Also known as:** GHSA-chj7-w3f6-cvfj, PYSEC-2026-444

## What is CVE-2024-0521?

CVE-2024-0521 is a critical vulnerability in paddlepaddle/paddle, published on 20 Jan 2024. 

### Official description

Code Injection in paddlepaddle/paddle

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-0521?

3 open source packages ship an affected version, including paddlepaddle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paddlepaddle` | PyPI | All versions | 2.6.0 |
| `paddlepaddle` | PyPI | All versions | 2.6.0 |
| `paddlepaddle` | PyPI | All versions | 2.6.0 |

Products: Paddlepaddle Paddle.

## How do I fix CVE-2024-0521?

Upgrade paddlepaddle to 2.6.0 or later.

## Is CVE-2024-0521 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0521 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0521 and fix it if it is affected.

What it is: CVE-2024-0521 is a critical vulnerability in paddlepaddle/paddle, published on 20 Jan 2024. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0521 exists.

Affected packages and fixed versions:
- paddlepaddle (PyPI): affected all versions; fixed in 2.6.0
- paddlepaddle (PyPI): affected all versions; fixed in 2.6.0
- paddlepaddle (PyPI): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0521/ (Markdown: https://insights.sbomify.com/CVE-2024-0521/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0521
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0521
- OSV: https://osv.dev/vulnerability/CVE-2024-0521

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0521/
Summaries are generated and may contain mistakes; the official description above is the record.
