CVE-2024-0669 Cross-Frame Scripting (XFS) on Plone CMS

Medium 6.3 Published Updated

An attacker can inject malicious iframes via stored URLs, potentially executing code or taking over administrator accounts in Plone CMS.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-0669?

CVE-2024-0669 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 18 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Cross-Frame Scripting vulnerability has been found on Plone CMS affecting verssion below 6.0.5. An attacker could store a malicious URL to be opened by an administrator and execute a malicios iframe element.

Weakness: CWE-1021

Which versions are affected by CVE-2024-0669?

3 open source packages ship an affected version, including plone and Plone. It affects 1 product.

PackageAffectedFixed in
plone PyPIAll versions6.0.7
plone PyPIAll versions6.0.7
Plone PyPIAll versions6.0.7

Products include Plone Plone.

How do I fix CVE-2024-0669?

Upgrade plone to 6.0.7 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-0669 being exploited?

There is no known exploitation of CVE-2024-0669 in the wild and no public exploit code.

All Plone Plone vulnerabilities

Sources

Also known as GHSA-5xfx-55x4-j223, PYSEC-2026-1797.

Is CVE-2024-0669 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free