# CVE-2024-0815: PaddlePaddle command injection in paddle.utils.download._wget_download

> Attackers can execute arbitrary commands via a bypass in the download utility of the PaddlePaddle deep learning library.

- **Severity:** Critical 9.3 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-qqv2-35q8-p2g2, PYSEC-2026-1756

## What is CVE-2024-0815?

CVE-2024-0815 is a critical command injection vulnerability in paddlepaddle/paddle, published on 7 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Command injection in paddle.utils.download._wget_download (bypass filter) in paddlepaddle/paddle 2.6.0

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2024-0815?

3 open source packages ship an affected version, including paddlepaddle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paddlepaddle` | PyPI | All versions to 2.6.0 | None |
| `paddlepaddle` | PyPI | All versions to 2.6.0 | None |
| `paddlepaddle` | PyPI | All versions | 3.0.0-beta0 |

Products: Paddlepaddle Paddlepaddle.

## How do I fix CVE-2024-0815?

Upgrade paddlepaddle to 3.0.0-beta0 or later.

## Is CVE-2024-0815 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0815 exists.

## Other vulnerabilities in paddlepaddle/paddle

- [CVE-2022-46742](https://insights.sbomify.com/CVE-2022-46742/): PaddlePaddle vulnerable to Code Injection (critical 10.0)
- [CVE-2022-45908](https://insights.sbomify.com/CVE-2022-45908/): PaddlePaddle vulnerable to code injection via winstr (critical 9.8)
- [CVE-2023-52310](https://insights.sbomify.com/CVE-2023-52310/): Command injection in get_online_pass_interval (critical 9.6)
- [CVE-2023-52311](https://insights.sbomify.com/CVE-2023-52311/): Command injection in _wget_download (critical 9.6)
- [CVE-2023-52314](https://insights.sbomify.com/CVE-2023-52314/): Command injection in convert_shape_compare (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0815 and fix it if it is affected.

What it is: CVE-2024-0815 is a critical command injection vulnerability in paddlepaddle/paddle, published on 7 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0815 exists.

Affected packages and fixed versions:
- paddlepaddle (PyPI): affected all versions up to 2.6.0; no fix listed
- paddlepaddle (PyPI): affected all versions up to 2.6.0; no fix listed
- paddlepaddle (PyPI): affected all versions; fixed in 3.0.0-beta0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0815/ (Markdown: https://insights.sbomify.com/CVE-2024-0815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0815
- OSV: https://osv.dev/vulnerability/CVE-2024-0815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0815/
Summaries are generated and may contain mistakes; the official description above is the record.
