{"answers":{"affected":"3 open source packages ship an affected version, including paddlepaddle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0817 exists.","fix":"Upgrade paddlepaddle to 3.0.0-beta0 or later.","what":"CVE-2024-0817 is a critical command injection vulnerability in paddlepaddle/paddle, published on 7 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-0817 and fix it if it is affected.\n\nWhat it is: CVE-2024-0817 is a critical command injection vulnerability in paddlepaddle/paddle, published on 7 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0817 exists.\n\nAffected packages and fixed versions:\n- paddlepaddle (PyPI): affected all versions up to 2.6.0; no fix listed\n- paddlepaddle (PyPI): affected all versions up to 2.6.0; no fix listed\n- paddlepaddle (PyPI): affected all versions; fixed in 3.0.0-beta0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-0817/ (Markdown: https://insights.sbomify.com/CVE-2024-0817/index.md)","id":"CVE-2024-0817","markdown":"https://insights.sbomify.com/CVE-2024-0817/index.md","name":"CVE-2024-0817","record":{"aliases":["GHSA-fh54-3vhg-mpc2","PYSEC-2026-1754"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PaddlePaddle deep learning library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via the IrGraph.draw function in the PaddlePaddle deep learning library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"paddlepaddle","vendor":"paddlepaddle"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Command injection in IrGraph.draw in paddlepaddle/paddle 2.6.0","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PaddlePaddle command injection vulnerability","id":"CVE-2024-0817","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"PaddlePaddle Path Traversal vulnerability","id":"CVE-2024-0818"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["2.6.0"],"package":"paddlepaddle","purl":null,"source":"GHSA-fh54-3vhg-mpc2"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["2.6.0"],"package":"paddlepaddle","purl":"pkg:pypi/paddlepaddle","source":"GHSA-fh54-3vhg-mpc2"},{"ecosystem":"PyPI","fixed":["3.0.0-beta0"],"introduced":["0"],"last_affected":[],"package":"paddlepaddle","purl":"pkg:pypi/paddlepaddle","source":"PYSEC-2026-1754"}],"prev":{"headline":"Memory corruption in DX3300-T1 firmware","id":"CVE-2024-0816"},"products":["paddlepaddle/paddle"],"published":"2024-03-07","related":[{"cvss_score":10,"headline":"PaddlePaddle vulnerable to Code Injection","id":"CVE-2022-46742","kev_date_added":null,"published":"2022-12-07"},{"cvss_score":9.8,"headline":"PaddlePaddle vulnerable to code injection via winstr","id":"CVE-2022-45908","kev_date_added":null,"published":"2022-11-26"},{"cvss_score":9.6,"headline":"Command injection in get_online_pass_interval","id":"CVE-2023-52310","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in _wget_download","id":"CVE-2023-52311","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in convert_shape_compare","id":"CVE-2023-52314","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in fs.py","id":"CVE-2023-38673","kev_date_added":null,"published":"2023-07-26"},{"cvss_score":9.4,"headline":"PaddlePaddle vulnerable to remote code execution","id":"CVE-2024-0917","kev_date_added":null,"published":"2024-03-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-16","vendors":["paddlepaddle"]},"summary":"Attackers can execute arbitrary commands via the IrGraph.draw function in the PaddlePaddle deep learning library.","url":"https://insights.sbomify.com/CVE-2024-0817/"}