# CVE-2024-0831: Vault May Expose Sensitive Information When Configuring An Audit Log Device

> Attackers can read sensitive data from audit logs when the log_raw option is enabled, affecting HashiCorp Vault deployments.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-vault-2024-0831, GHSA-vgh3-mwxq-rcp8, GO-2024-2511

## What is CVE-2024-0831?

CVE-2024-0831 is a medium-severity vulnerability in Hashicorp Vault, published on 1 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Vault and Vault Enterprise (“Vault”) may expose sensitive information when enabling an audit device which specifies the `log_raw` option, which may log sensitive information to other audit devices, regardless of whether they are configured to use `log_raw`.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-0831?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 1.15.0 | 1.15.5 |
| `github.com/hashicorp/vault` | Go | From 1.15.0 | 1.15.5 |
| `github.com/hashicorp/vault` | Go | From 1.15.0 | 1.15.5 |
| `vault` | Bitnami | From 1.15.0 | 1.15.5 |

Products: Hashicorp Vault.

## How do I fix CVE-2024-0831?

Upgrade github.com/hashicorp/vault to 1.15.5 or later.

## Is CVE-2024-0831 being exploited?

There is no known exploitation of CVE-2024-0831 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0831 and fix it if it is affected.

What it is: CVE-2024-0831 is a medium-severity vulnerability in Hashicorp Vault, published on 1 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-0831 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 1.15.0; fixed in 1.15.5
- github.com/hashicorp/vault (Go): affected from 1.15.0; fixed in 1.15.5
- github.com/hashicorp/vault (Go): affected from 1.15.0; fixed in 1.15.5
- vault (Bitnami): affected from 1.15.0; fixed in 1.15.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0831/ (Markdown: https://insights.sbomify.com/CVE-2024-0831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0831
- OSV: https://osv.dev/vulnerability/CVE-2024-0831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0831/
Summaries are generated and may contain mistakes; the official description above is the record.
