CVE-2024-0861 Direct Request ('Forced Browsing') in GitLab
Guest users can modify custom dashboard project settings in GitLab EE, violating intended permission restrictions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-0861?
CVE-2024-0861 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 21 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 16.4 before 16.7.6, all versions starting from 16.8 before 16.8.3, all versions starting from 16.9 before 16.9.1. Users with the `Guest` role can change `Custom dashboard projects` settings contrary to permissions.
Weakness: CWE-425
Which versions are affected by CVE-2024-0861?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.4.0 | 16.7.6, 16.8.3, 16.9.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-0861?
Upgrade gitlab to a fixed version for your release line: 16.7.6, 16.8.3 or 16.9.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-0861 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0861 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-0861, GHSA-32j2-p2qq-hh3c, UBUNTU-CVE-2024-0861.