# CVE-2024-0861: Direct Request ('Forced Browsing') in GitLab

> Guest users can modify custom dashboard project settings in GitLab EE, violating intended permission restrictions.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2024
- **Updated:** 1 May 2026
- **Also known as:** BIT-gitlab-2024-0861, GHSA-32j2-p2qq-hh3c, UBUNTU-CVE-2024-0861

## What is CVE-2024-0861?

CVE-2024-0861 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 21 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue has been discovered in GitLab EE affecting all versions starting from 16.4 before 16.7.6, all versions starting from 16.8 before 16.8.3, all versions starting from 16.9 before 16.9.1. Users with the `Guest` role can change `Custom dashboard projects` settings contrary to permissions.

Weakness: CWE-425 (Direct Request)

## Which versions are affected by CVE-2024-0861?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.4.0 | 16.7.6, 16.8.3, 16.9.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-0861?

Upgrade gitlab to a fixed version for your release line: 16.7.6, 16.8.3 or 16.9.1.

## Is CVE-2024-0861 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0861 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0861 and fix it if it is affected.

What it is: CVE-2024-0861 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 21 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0861 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.4.0; fixed in 16.7.6, 16.8.3, 16.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0861/ (Markdown: https://insights.sbomify.com/CVE-2024-0861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0861
- OSV: https://osv.dev/vulnerability/CVE-2024-0861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0861/
Summaries are generated and may contain mistakes; the official description above is the record.
