# CVE-2024-0902: Fancy Product Designer < 6.1.81 - Admin+ Cross Site Scripting via Product Title

> Admins can inject malicious scripts via product titles in Fancy Product Designer, enabling XSS attacks in multisite setups.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Apr 2024
- **Updated:** 26 Mar 2025
- **Also known as:** GHSA-27c4-r889-j59x

## What is CVE-2024-0902?

CVE-2024-0902 is a medium-severity cross-site scripting vulnerability in Unknown Fancy Product Designer, published on 15 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The Fancy Product Designer WordPress plugin before 6.1.81 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-0902?

It affects 1 product.


Products: Radykal Fancy Product Designer.

## How do I fix CVE-2024-0902?

No fix has been published for CVE-2024-0902 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-0902 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0902 exists.

## Other vulnerabilities in Unknown Fancy Product Designer

- [CVE-2021-24370](https://insights.sbomify.com/CVE-2021-24370/): Fancy Product Designer < 4.6.9 - Unauthenticated Arbitrary File Upload and RCE (critical 9.8)
- [CVE-2021-4334](https://insights.sbomify.com/CVE-2021-4334/): Fancy Product Designer <= 4.6.9 - Insufficient Authorization to Arbitrary Options Update via fpd_update_options (high 8.8)
- [CVE-2021-4096](https://insights.sbomify.com/CVE-2021-4096/): Fancy Product Designer <= 4.7.5 - Cross-Site Request Forgery to Arbitrary File Upload (high 8.8)
- [CVE-2021-4134](https://insights.sbomify.com/CVE-2021-4134/): Fancy Product Designer <= 4.7.4 Admin+ SQL Injection (high 7.2)
- [CVE-2024-0365](https://insights.sbomify.com/CVE-2024-0365/): Fancy Product Designer < 6.1.5 - Admin+ SQL Injection (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-0902 and fix it if it is affected.

What it is: CVE-2024-0902 is a medium-severity cross-site scripting vulnerability in Unknown Fancy Product Designer, published on 15 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-0902 exists.

Affected product: Unknown Fancy Product Designer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-0902/ (Markdown: https://insights.sbomify.com/CVE-2024-0902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-0902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-0902
- OSV: https://osv.dev/vulnerability/CVE-2024-0902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-0902/
Summaries are generated and may contain mistakes; the official description above is the record.
