CVE-2024-0981 Cross-site scripting in Okta Browser Plugin
Cross-site scripting in Okta Browser Plugin allows attackers to execute scripts when users save credentials, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2024-0981?
CVE-2024-0981 is a high-severity cross-site scripting vulnerability in Okta Browser Plugin, published on 23 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Okta Browser Plugin versions 6.5.0 through 6.31.0 (Chrome/Edge/Firefox/Safari) are vulnerable to cross-site scripting. This issue occurs when the plugin prompts the user to save these credentials within Okta Personal. A fix was implemented to properly escape these fields, addressing the vulnerability. Importantly, if Okta Personal is not added to the plugin to enable multi-account view, the Workforce Identity Cloud plugin is not affected by this issue. The vulnerability is fixed in Okta Browser Plugin version 6.32.0 for Chrome/Edge/Safari/Firefox.
Weakness: CWE-79
Which versions are affected by CVE-2024-0981?
How do I fix CVE-2024-0981?
No fix has been published for CVE-2024-0981 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-0981 being exploited?
There is no known exploitation of CVE-2024-0981 in the wild and no public exploit code.
Sources
Also known as GHSA-72w8-4vgg-vh67.