# CVE-2024-10006: Consul L7 Intentions Vulnerable To Headers Bypass

> Attackers can bypass HTTP header-based access rules in Consul L7 intentions, potentially accessing restricted services.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2024
- **Updated:** 10 Jan 2025
- **Also known as:** BIT-consul-2024-10006, CLEANSTART-2026-TK35937, DEBIAN-CVE-2024-10006, GHSA-5c4w-8hhh-3c3h, GO-2024-3241, UBUNTU-CVE-2024-10006

## What is CVE-2024-10006?

CVE-2024-10006 is a high-severity vulnerability in HashiCorp Consul, published on 30 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was identified in Consul and Consul Enterprise (“Consul”) such that using Headers in L7 traffic intentions could bypass HTTP header based access rules.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-644 (Improper Neutralization of HTTP Headers for Scripting Syntax)

## Which versions are affected by CVE-2024-10006?

4 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | From 1.9.0 | 1.20.1 |
| `github.com/hashicorp/consul` | Go | From 1.9.0 | 1.20.1 |
| `github.com/hashicorp/consul` | Go | From 1.9.0 | 1.20.1 |
| `consul` | Bitnami | From 1.9.0 | 1.20.1 |

Products: Hashicorp Consul.

## How do I fix CVE-2024-10006?

Upgrade github.com/hashicorp/consul to 1.20.1 or later.

## Is CVE-2024-10006 being exploited?

There is no known exploitation of CVE-2024-10006 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Consul

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2023-2816](https://insights.sbomify.com/CVE-2023-2816/): Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner (high 8.7)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)
- [CVE-2019-8336](https://insights.sbomify.com/CVE-2019-8336/): HashiCorp Consul Access Restriction Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10006 and fix it if it is affected.

What it is: CVE-2024-10006 is a high-severity vulnerability in HashiCorp Consul, published on 30 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-10006 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected from 1.9.0; fixed in 1.20.1
- github.com/hashicorp/consul (Go): affected from 1.9.0; fixed in 1.20.1
- github.com/hashicorp/consul (Go): affected from 1.9.0; fixed in 1.20.1
- consul (Bitnami): affected from 1.9.0; fixed in 1.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10006/ (Markdown: https://insights.sbomify.com/CVE-2024-10006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10006
- OSV: https://osv.dev/vulnerability/CVE-2024-10006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10006/
Summaries are generated and may contain mistakes; the official description above is the record.
