{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-10007 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-10007 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-10007 is a high-severity path traversal vulnerability in Github Enterprise Server, published on 7 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-10007 and fix it if it is affected.\n\nWhat it is: CVE-2024-10007 is a high-severity path traversal vulnerability in Github Enterprise Server, published on 7 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-10007 in the wild and no public exploit code.\n\nAffected product: Github Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-10007/ (Markdown: https://insights.sbomify.com/CVE-2024-10007/index.md)","id":"CVE-2024-10007","markdown":"https://insights.sbomify.com/CVE-2024-10007/index.md","name":"CVE-2024-10007","record":{"aliases":["GHSA-8w9v-ch8x-63jr"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GitHub Enterprise Server","requires_auth":"high_privilege","summary":"Privileged users can exploit path collisions to escape containers and gain root access on GitHub Enterprise Server instances.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_P","cpe":[{"product":"enterprise_server","vendor":"github"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"A path collision and arbitrary code execution vulnerability was identified in GitHub Enterprise Server that allowed container escape to escalate to root via ghe-firejail path. Exploitation of this vulnerability requires Enterprise Administrator access to the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise prior to 3.15 and was fixed in versions 3.14.3, 3.13.6, 3.12.11, and 3.11.17. This vulnerability was reported via the GitHub Bug Bounty program.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Pre-Receive Hook Path Collision Vulnerability in GitHub Enterprise Server Allowing Privilege Escalation","id":"CVE-2024-10007","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"github:enterprise_server","products":["github:enterprise_server"],"type":"path_traversal","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"Missing authorization in Masteriyo LMS – Online Course Builder for eLearning, LMS \u0026 Education","id":"CVE-2024-10008"},"packages":[],"prev":{"headline":"Consul L7 Intentions Vulnerable To Headers Bypass","id":"CVE-2024-10006"},"products":["Enterprise Server"],"published":"2024-11-07","related":[{"cvss_score":10,"headline":"Auth bypass in Enterprise Server","id":"CVE-2024-4985","kev_date_added":null,"published":"2024-05-20"},{"cvss_score":9.8,"headline":"Missing authorization in GitHub Enterprise Server","id":"CVE-2022-23739","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":9.8,"headline":"Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE","id":"CVE-2022-46255","kev_date_added":null,"published":"2022-12-14"},{"cvss_score":9.8,"headline":"Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group","id":"CVE-2021-22869","kev_date_added":null,"published":"2021-09-24"},{"cvss_score":9.5,"headline":"Auth bypass in Enterprise Server","id":"CVE-2024-9487","kev_date_added":null,"published":"2024-10-10"},{"cvss_score":9.5,"headline":"Auth bypass in GitHub Enterprise Server","id":"CVE-2024-6800","kev_date_added":null,"published":"2024-08-20"},{"cvss_score":9.3,"headline":"GitHub Enterprise Server notebook viewer vulnerable to Server-side request forgery","id":"CVE-2026-77987","kev_date_added":null,"published":"2026-09-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-08","vendors":["GitHub"]},"summary":"Privileged users can exploit path collisions to escape containers and gain root access on GitHub Enterprise Server instances.","url":"https://insights.sbomify.com/CVE-2024-10007/"}