CVE-2024-10043 Incorrect Authorization in GitLab

Low 3.1 Published Updated

Group users can view confidential incident titles via Wiki History Diff, leading to information disclosure in GitLab EE.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-10043?

CVE-2024-10043 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 12 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 14.3 before 17.4.6, all versions starting from 17.5 before 17.5.4 all versions starting from 17.6 before 17.6.2, that allows group users to view confidential incident title through the Wiki History Diff feature, potentially leading to information disclosure.

Weakness: CWE-863

Which versions are affected by CVE-2024-10043?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.3.017.4.6, 17.5.4, 17.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-10043?

Upgrade gitlab to a fixed version for your release line: 17.4.6, 17.5.4 or 17.6.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-10043 being exploited?

There is no known exploitation of CVE-2024-10043 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-10043, GHSA-5fpq-xm8v-3843, UBUNTU-CVE-2024-10043.

Is CVE-2024-10043 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free