CVE-2024-10073 flairNLP flair Mode File Loader clustering.py ClusteringModel code injection

Medium 6.3 Published Updated

Attackers can execute arbitrary code via the ClusteringModel in flairNLP flair, requiring high complexity and permissions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-10073?

CVE-2024-10073 is a medium-severity code injection vulnerability in flairNLP flair, published on 17 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability, which was classified as critical, was found in flairNLP flair 0.14.0. Affected is the function ClusteringModel of the file flair\models\clustering.py of the component Mode File Loader. The manipulation leads to code injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-94

Which versions are affected by CVE-2024-10073?

3 open source packages ship an affected version, including flair. It affects 1 product.

PackageAffectedFixed in
flair PyPIAll versions0.15.0
flair PyPIAll versions0.15.0
flair PyPIAll versions0.15.0

Products include Informatik.hu-Berlin Flair.

How do I fix CVE-2024-10073?

Upgrade flair to 0.15.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-10073 being exploited?

There is no known exploitation of CVE-2024-10073 in the wild and no public exploit code.

Sources

Also known as GHSA-9rw2-jf8x-cgwm, PYSEC-2026-1376.

Is CVE-2024-10073 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free