{"answers":{"affected":"3 open source packages ship an affected version, including flair. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-10073 in the wild and no public exploit code.","fix":"Upgrade flair to 0.15.0 or later.","what":"CVE-2024-10073 is a medium-severity code injection vulnerability in flairNLP flair, published on 17 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-10073 and fix it if it is affected.\n\nWhat it is: CVE-2024-10073 is a medium-severity code injection vulnerability in flairNLP flair, published on 17 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-10073 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flair (PyPI): affected all versions; fixed in 0.15.0\n- flair (PyPI): affected all versions; fixed in 0.15.0\n- flair (PyPI): affected all versions; fixed in 0.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-10073/ (Markdown: https://insights.sbomify.com/CVE-2024-10073/index.md)","id":"CVE-2024-10073","markdown":"https://insights.sbomify.com/CVE-2024-10073/index.md","name":"CVE-2024-10073","record":{"aliases":["GHSA-9rw2-jf8x-cgwm","PYSEC-2026-1376"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python NLP library","requires_auth":"none","summary":"Attackers can execute arbitrary code via the ClusteringModel in flairNLP flair, requiring high complexity and permissions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"flair","vendor":"informatik.hu-berlin"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"A vulnerability, which was classified as critical, was found in flairNLP flair 0.14.0. Affected is the function ClusteringModel of the file flair\\models\\clustering.py of the component Mode File Loader. The manipulation leads to code injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"flairNLP flair Mode File Loader clustering.py ClusteringModel code injection","id":"CVE-2024-10073","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":5,"next":{"headline":"Liteos_a has an use after free vulnerability","id":"CVE-2024-10074"},"packages":[{"ecosystem":"PyPI","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"flair","purl":null,"source":"GHSA-9rw2-jf8x-cgwm"},{"ecosystem":"PyPI","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"flair","purl":"pkg:pypi/flair","source":"GHSA-9rw2-jf8x-cgwm"},{"ecosystem":"PyPI","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"flair","purl":"pkg:pypi/flair","source":"PYSEC-2026-1376"}],"prev":{"headline":"ESAFENET CDG EncryptPolicyService.java actionAddEncryptPolicyGroup sql injection","id":"CVE-2024-10072"},"products":["flair"],"published":"2024-10-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-17","vendors":["flairNLP"]},"summary":"Attackers can execute arbitrary code via the ClusteringModel in flairNLP flair, requiring high complexity and permissions.","url":"https://insights.sbomify.com/CVE-2024-10073/"}