# CVE-2024-10073: flairNLP flair Mode File Loader clustering.py ClusteringModel code injection

> Attackers can execute arbitrary code via the ClusteringModel in flairNLP flair, requiring high complexity and permissions.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2024
- **Updated:** 17 Oct 2024
- **Also known as:** GHSA-9rw2-jf8x-cgwm, PYSEC-2026-1376

## What is CVE-2024-10073?

CVE-2024-10073 is a medium-severity code injection vulnerability in flairNLP flair, published on 17 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, was found in flairNLP flair 0.14.0. Affected is the function ClusteringModel of the file flair\models\clustering.py of the component Mode File Loader. The manipulation leads to code injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-10073?

3 open source packages ship an affected version, including flair. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flair` | PyPI | All versions | 0.15.0 |
| `flair` | PyPI | All versions | 0.15.0 |
| `flair` | PyPI | All versions | 0.15.0 |

Products: Informatik.hu-Berlin Flair.

## How do I fix CVE-2024-10073?

Upgrade flair to 0.15.0 or later.

## Is CVE-2024-10073 being exploited?

There is no known exploitation of CVE-2024-10073 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10073 and fix it if it is affected.

What it is: CVE-2024-10073 is a medium-severity code injection vulnerability in flairNLP flair, published on 17 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-10073 in the wild and no public exploit code.

Affected packages and fixed versions:
- flair (PyPI): affected all versions; fixed in 0.15.0
- flair (PyPI): affected all versions; fixed in 0.15.0
- flair (PyPI): affected all versions; fixed in 0.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10073/ (Markdown: https://insights.sbomify.com/CVE-2024-10073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10073
- OSV: https://osv.dev/vulnerability/CVE-2024-10073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10073/
Summaries are generated and may contain mistakes; the official description above is the record.
